Intermittent platform degradation due to large scale AWS incident.

Incident Report for Zylo

Resolved

Zylo has concluded that as As of 01:00 UTC, this issue has been resolved. Zylo's monitoring since that time has confirmed as such. If you believe you are having residual issues, please contact your Zylo account representative or open a support ticket.
Posted Oct 21, 2025 - 17:25 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 21, 2025 - 12:50 UTC

Update

Zylo has concluded that the system is operating per normal. We are continuing to monitor overnight to ensure stats and integrations do not have additional issues.
Posted Oct 21, 2025 - 01:00 UTC

Update

Zylo's end-users should see incrementally improved performance within Zylo's platform as AWS has made progress in restoring their services to normal operation. Zylo continues to assess and work towards ensuring availability of our platform while AWS continues with its remediations. Additional updates will be provided as information becomes available.
Posted Oct 20, 2025 - 21:21 UTC

Monitoring

Zylo is experiencing intermittent degraded platform performance as a result of larger AWS service degradation. Some functionality may require additional wait times, or could result in periodic timeouts. Zylo staff are conducting ongoing assessments and working to ensure availability of our platform as we adjust to AWS remediation steps. Additional updates will be provided as information becomes available.
Posted Oct 20, 2025 - 18:21 UTC
This incident affected: Zylo Application and API service.